UPiS remain in BAT even if USB power come back

Uninterruptible Power intelligent Supply Module

UPiS remain in BAT even if USB power come back

Postby flyvert » Mon Jul 11, 2016 9:30 pm

Hi

Me again, new thread since I got no answer on my previous attempt.

My UPiS have a fault - it "works" but fail to detect resumed USB power after a short period with no USB power.
Today my house's earth fault breaker tripped (I was at blame for that) and I had it reset (on again) within just two or three minutes.

And the story with my UPiS continues; it carries my Rasperry Pi very well during the outage, but only until the battery is depleted. If fail to detect restored power. I need to push the UPiS reset button to have it to power up again.

The purple trend (mode) indicate BAT for roughly 30 minutes, this is wrong. USB power was restored within three (3) minutes!
When battery becomes too low, a proper shutdown is called. However, it will remain in OFF state until I reset.
After reset the battery is properly charged again.

WHEN WILL THIS FLAW BE FIXED???

Pity that the promised fixes never see daylight...

2016-07-11 22-19-27.png
Battery trends
2016-07-11 22-19-27.png (187.73 KiB) Viewed 1015 times


@status
----------------------
http://www.pimodules.com
UPiS Advanced
Firmware Version:1.096 Beta Version
Hardware Release:VCO2
flyvert
 
Posts: 26
Joined: Sat Jul 19, 2014 1:22 pm

Re: UPiS remain in BAT even if USB power come back

Postby SlySven » Thu Jul 21, 2016 1:50 am

I'm seeing something which I think is similar with my UPiS basic attached to a RPi B - the trouble I think is that the current draw of ~500mA is right on the current limit for my 1.00 software and it does not like to turn the charger on automatically as that will take it up to around 720mA which I think exceeds an internal limit (EDIT: AFTER READING REVISION 1.11 MANUAL p62 THE LIMIT IS APPARENTLY 750mA!) at which point the UPiS decides "OK - I haven't got enough current to run the RPi and charge the battery so I won't charge the battery just yet...". Sending a "@CHRG ON" down the serial port sometimes works to cause the charger to start putting juice back into the battery once the mains has returned but it is impossible to tell precisely as I am also finding the reporting of the charger state back via the serial port does not match the "CHG" LED (it reports the charger being ON even when the LED is off and the battery voltage is stable/static and around the charged 4.2V level!)

I do wonder at what point the UPiS decides that the incoming voltage on it's USB input is TOO LOW (and also what the TOO HIGH level is as well, for the record) and it has to provide power from it's internal Battery rather than using a supply that it deems is out of specification - guess I need to dig out my bench supply and do a check. I have trimmed the supply into the UPiS to be a little above 5.00V (at this point the UPiS is reporting 5.16V) as I think that might help a little to convince the unit that it does have a good supply - I do suspect that some "Wall-warts" do not really supply an accurately regulated 5V at 1 or 2A on their output - though whatever it is that are you using does seem to be reasonable.

Also - where is the "Mains Outage" on your chart - I am assuming the following key:
"Spänning" = Internal RPi +5V line
"Ström" = Total Current
"UPiS batteri" = Battery Voltage
"UPiS driftmod" = Power Source
"UPiS matning" = USB Input Connector Voltage
so where is the bit where the red trace drops to near zero - or is the sample rate less than the duration of the actual outage? I note that it is closer to 5.0V during the time that the UPiS is (mistakenly) running off the battery rather than re-charging compared to the remaining time when the system seems to be operating correctly.

I also notice that there are a couple of spikes on that particular trace, to a voltage in excess of 5.7 Volts, and the second of those seems to be at the point where the battery charge/voltage has just about reached full and I guess the charger has switched off. I also am getting odd high levels around the time of Main->Battery source switching as though the high incoming supply level forces a switch to battery mode - though I have wondered whether the ADC circuitry just goes a bit funny when the power supply source changes...

Stephen
BEng(Hons) - Electrical & Electronic Engineering !!!
SlySven
 
Posts: 18
Joined: Tue Feb 23, 2016 4:55 am


Return to UPiS

Who is online

Users browsing this forum: No registered users and 1 guest

cron