i2cdetect does not detect UPS PIco but UPS works

Support for the UPS PIco HV3.0A, UPS PIco HV3.0 A Plus, UPS PIco HV3.0A Terminal Block products, sd also for updated hardware HV3.0B

i2cdetect does not detect UPS PIco but UPS works

Postby lpc » Tue May 02, 2017 5:00 pm

Hi,

My system was fine, the UPS worked correctly as did the RTC and running the pico_status_hv3.0.py script.

After one particular reboot this morning, for no apparant reason no interaction between the pi and the i2c registers seems possible, although the UPS still works on a power failure, and the LED still blinks correctly.

Examples of attempts to interact with the pico:

Code: Select all
pi@:~ $  sudo i2cdetect -y 1
     0  1  2  3  4  5  6  7  8  9  a  b  c  d  e  f
00:          -- -- -- -- -- -- -- -- -- -- -- -- --
10: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
20: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
30: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
40: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
50: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
60: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
70: -- -- -- -- -- -- -- --
pi@:~ $ sudo python /home/pi/PiModules/pico_status/pico_status_hv3.0.py

***********************************
      UPS PIco HV3.0A Status
***********************************

  UPS PIco Firmware.....:
Traceback (most recent call last):
  File "/home/pi/PiModules/pico_status/pico_status_hv3.0.py", line 186, in <module>
    print " ","UPS PIco Firmware.....:",fw_version()
  File "/home/pi/PiModules/pico_status/pico_status_hv3.0.py", line 29, in fw_version
    data = i2c.read_byte_data(0x69, 0x26)
IOError: [Errno 110] Connection timed out

pi@:~ $ sudo hwclock -r
hwclock: Cannot access the Hardware Clock via any known method.
hwclock: Use the --debug option to see the details of our search for an access method.


Multiple reboots and power cyycles haven't sorted this out. Can you suggest anything?

Thanks,
Luther
lpc
 
Posts: 9
Joined: Tue Feb 28, 2017 6:09 pm

Re: i2cdetect does not detect UPS PIco but UPS works

Postby mivo » Wed May 03, 2017 6:43 am

lpc wrote:Hi,

My system was fine, the UPS worked correctly as did the RTC and running the pico_status_hv3.0.py script.

After one particular reboot this morning, for no apparant reason no interaction between the pi and the i2c registers seems possible, although the UPS still works on a power failure, and the LED still blinks correctly.

Hi,

please try to restart PIco with "UR" button. It should make start sequence - 3 user LEDs go on for about 2sec, and then go off. "UPS" LED then goes on, and start blinking if getting response from PICOFSSD daemon. Then try again i2cdetect:
Code: Select all
pi@:~ $  sudo i2cdetect -y 1
My toys:
Raspberry Pi 3 + UPS PIco HV3.0 A Stack
Minibian (Raspbian Jessie) + Domoticz beta

RaZberry module + 2x Comet Z-Wave + Z-wave socket
WeMo Switch
mivo
 
Posts: 25
Joined: Fri Apr 21, 2017 9:11 pm
Location: Czechia

Re: i2cdetect does not detect UPS PIco but UPS works

Postby lpc » Wed May 03, 2017 10:18 am

Thanks, this did the trick. It would be helpful to understand why the PIco got into this state in the first place and how we can avoid it happening again. I can't think of what we did that caused it to happen, we weren't doing much in software and little if anything that involved touching the pi or PIco or switching stuff off & on etc, but apparently after one 'sudo reboot' command the PIco registers were then unreadable.

We are wondering if on our industrial products which feature the pi and the PIco we should wire up an additional GPIO pin from the pi to the UR button so that a PIco reset can be initiated from software when the i2c registers become unreadable.

This could be avoided if we can guarantee we won't have the problem again. Can you give more information about what would cause the PIco to go into that unreadable state? We have seen it on other boards occasionally too. It's firmware version 31.

Cheers.
lpc
 
Posts: 9
Joined: Tue Feb 28, 2017 6:09 pm

Re: i2cdetect does not detect UPS PIco but UPS works

Postby lpc » Tue Jul 04, 2017 10:43 am

Hi again, if you were able to inform us at all on my latest post above, it would be most helpful. Thanks.
lpc
 
Posts: 9
Joined: Tue Feb 28, 2017 6:09 pm


Return to UPS PIco HV3.0A and HV3.0B

Who is online

Users browsing this forum: No registered users and 1 guest