HV 1.1 dead?

Support for the Uninterruptible Power Supply
with Peripherals and I2C control Interface
Raspberry Pi® B+, A+, B, and A

HV 1.1 dead?

Postby Zonked » Sat Jun 24, 2017 4:27 pm

Hi, this all seems very neglected and I'm wondering if someone can clear a few things up for me.

I have a HV 1.1 ups and it has done me well. It has ran for probably well over a year on my RPI2.

...That was until I updated Raspian a few weeks back and suddenly I couldn't set or get the IC2 variables for anything other than the RED and BLUE LED. It would just return 0xff for every other IC2 command. The fan cant be switched on and none of the temperatures can be returned. The FSSD button did still work and the UPS functioned normally when unplugged. I attempted to reinstall with one of the old manuals on your website but it has got me nowhere and I came across numerous problems. (it says for firmware version 25 at the top of the pdf, and im sure that is very out of date!)

So I gave up. Now all of a sudden, and seemingly from nowhere, it doesn't do anything at all. All the LEDs are off, but the charging LED remains on constantly, and the FSSD button doesn't respond. RPI reset and UPS reset buttons still work.

So is this project still being worked on or have I purchased an expensive paper weight that is now good for nothing? I see all the hype seems to be around this HV 3.0 now. Perhaps I should just get a new one, but then whats to say that wont be left to flounder in the future and I end up wasting more money?

I have tried to obtain a recent version of the firmware hoping it might fix things, but the only one I can find on your site is from way back in 25/02/2016. So can anyone tell me where to get the most recent firmware for HV 1.1 and provide me with instruction on how to update it, and then reinstall it on the most recent version of Raspian?

I'm a little disappointed in how this project has turned out, the site and forums seem very neglected and information is scarce. Its all very very confusing. :?

Thanks.
Zonked
 
Posts: 2
Joined: Sat Jun 24, 2017 4:05 pm

Re: HV 1.1 dead?

Postby Pimaster » Mon Jun 26, 2017 11:59 pm

Hi, this all seems very neglected and I'm wondering if someone can clear a few things up for me.
I have a HV 1.1 ups and it has done me well. It has ran for probably well over a year on my RPI2.

Hi,
OK


...That was until I updated Raspian a few weeks back and suddenly I couldn't set or get the IC2 variables for anything other than the RED and BLUE LED. It would just return 0xff for every other IC2 command. The fan cant be switched on and none of the temperatures can be returned. The FSSD button did still work and the UPS functioned normally when unplugged. I attempted to reinstall with one of the old manuals on your website but it has got me nowhere and I came across numerous problems. (it says for firmware version 25 at the top of the pdf, and im sure that is very out of date!)

You have updated the kernel to the newest one. We are working on it, but as the handling of the i2c changed it took little bit more time, was easy to do for the HV3.0 as it is 16 bits, more difficult for the former one. I have announced it on the forum, and asked to not update the kernel, for the moment
I also informed on the forum, the we are going to clone the complete firmware form the HV3.0 to the HV1.0 (the biggest part), so we wil l keep both devices compatible and similar in handling

So I gave up. Now all of a sudden, and seemingly from nowhere, it doesn't do anything at all. All the LEDs are off, but the charging LED remains on constantly, and the FSSD button doesn't respond. RPI reset and UPS reset buttons still work.
Please do not update the kernel until we solve this matter, they changed the I2C handling, I have announced it on the forum HV1.1

So is this project still being worked on or have I purchased an expensive paper weight that is now good for nothing? I see all the hype seems to be around this HV 3.0 now. Perhaps I should just get a new one, but then whats to say that wont be left to flounder in the future and I end up wasting more money?

This is still alive project and as informed you, soon we will have similar firmware (in functionality manner) in both devices

I have tried to obtain a recent version of the firmware hoping it might fix things, but the only one I can find on your site is from way back in 25/02/2016. So can anyone tell me where to get the most recent firmware for HV 1.1 and provide me with instruction on how to update it, and then reinstall it on the most recent version of Raspian?

The latest HV1.1 firmware was working very well, until kernel has changed their i2c clocking. As you know we ware not able to imaging that before one year. Luckily the bootloader solve this problem with new update, and we are working on it.

New web site is ready and hope in next 2 weeks will be released, so every required information will be on their place
Warmest Regards
PiM
---
Designing with Mentor Graphics PADS - www.pads.com
Please read and follow the PiForum rules
http://www.forum.pimodules.com/viewtopic.php?f=13&t=196
---
Pimaster
Site Admin
 
Posts: 1618
Joined: Fri Sep 14, 2012 7:50 am


Return to UPS PIco

Who is online

Users browsing this forum: No registered users and 2 guests

cron